Dolby Vision now possible through MP4 Mux.

Please post here for issues related to UHD discs
Message
Author
shawnc22
Posts: 626
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision now possible through MP4 Mux.

#1456 Post by shawnc22 » Fri Mar 06, 2020 2:21 am

RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
wonder if it may be because of the AI-enhanced upscaler? I know that it's only supposed to be used for regular HD videos, but maybe it's still doing something to these 4k videos.

RESET_9999
Posts: 506
Joined: Mon Aug 05, 2019 7:12 pm

Re: Dolby Vision now possible through MP4 Mux.

#1457 Post by RESET_9999 » Fri Mar 06, 2020 2:28 am

shawnc22 wrote:
Fri Mar 06, 2020 2:21 am

wonder if it may be because of the AI-enhanced upscaler? I know that it's only supposed to be used for regular HD videos, but maybe it's still doing something to these 4k videos.
nop... AI upscaler is turned off, I hate it. https://www.avsforum.com/forum/39-netwo ... st58785700

on my end, anything that needs upscaling goes into HTPC/madVR. :)
Please forgive my English.
Sony x700 ----> Denon AVR ----> LG OLED C8
FIX the x700 DT-DL TS bug with this file

smartrobot
Posts: 3
Joined: Sun Oct 28, 2018 9:44 pm

Re: Dolby Vision now possible through MP4 Mux.

#1458 Post by smartrobot » Fri Mar 06, 2020 4:35 am

Is anyone else having this issue with @yusesope tool
Throws an error and hangs the video works it is just missing the last second or so

I can still use the output and create a mp4 using dlb_mp4base and will play back on my Visio TV

FFMPEG output warnings

Code: Select all

[NULL @ 0x5568201f5c80] Invalid NAL unit 36, skipping.
[NULL @ 0x5568201f6e40] Invalid NAL unit 36, skipping.
yusesope output

Code: Select all

___@little-server:~/src$ python3 bl_el_rpu_builder.py -tbw 4 -bl ~/BL.hevc -el ~/EL.hevc -o ~/Out.hvec
Exception in thread Thread-1:LYSIS: 86.8%     BL_EL_RPU WRITING: 86.0%
Traceback (most recent call last):
  File "/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "bl_el_rpu_builder.py", line 175, in run
    self.read()
  File "bl_el_rpu_builder.py", line 163, in read
    self.get_nal_info(mm,length,global_offset)
  File "bl_el_rpu_builder.py", line 138, in get_nal_info
    nal_type = self.get_nal_type(mmap_obj[(nal_offset + 3):(nal_offset + 5)])
  File "bl_el_rpu_builder.py", line 128, in get_nal_type
    nuh_layer_id = b_stream.read('uint:6')
  File "/home/nick/.local/lib/python3.6/site-packages/bitstring.py", line 3902, in read
    value, self._pos = self._readtoken(name, self._pos, length)
  File "/home/nick/.local/lib/python3.6/site-packages/bitstring.py", line 2016, in _readtoken
    "Tried to read {0} bits when only {1} available.".format(int(length), self.length - pos))
bitstring.ReadError: Reading off the end of the data. Tried to read 6 bits when only 1 available.

Exception in thread Thread-2:LYSIS: 92.4%     BL_EL_RPU WRITING: 91.3%
Traceback (most recent call last):
  File "/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "bl_el_rpu_builder.py", line 175, in run
    self.read()
  File "bl_el_rpu_builder.py", line 163, in read
    self.get_nal_info(mm,length,global_offset)
  File "bl_el_rpu_builder.py", line 138, in get_nal_info
    nal_type = self.get_nal_type(mmap_obj[(nal_offset + 3):(nal_offset + 5)])
  File "bl_el_rpu_builder.py", line 128, in get_nal_type
    nuh_layer_id = b_stream.read('uint:6')
  File "~/.local/lib/python3.6/site-packages/bitstring.py", line 3902, in read
    value, self._pos = self._readtoken(name, self._pos, length)
  File "~/.local/lib/python3.6/site-packages/bitstring.py", line 2016, in _readtoken
    "Tried to read {0} bits when only {1} available.".format(int(length), self.length - pos))
bitstring.ReadError: Reading off the end of the data. Tried to read 6 bits when only 1 available.

BL ANALYSIS: 99.3%     EL ANALYSIS: 99.3%     BL_EL_RPU WRITING: 99.3%


Arbigator
Posts: 32
Joined: Fri Feb 28, 2020 9:16 pm

Re: Dolby Vision now possible through MP4 Mux.

#1459 Post by Arbigator » Fri Mar 06, 2020 5:26 am

RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
Have you tried setting the Shield's output to YUV 4:2:0 10 bit or YUV 4:2:2 12 bit rather than RGB 8 bit? I could definitely see things looking different if not set to YUV.

FusionNeo
Posts: 21
Joined: Sat Nov 02, 2019 1:15 pm

Re: Dolby Vision now possible through MP4 Mux.

#1460 Post by FusionNeo » Fri Mar 06, 2020 6:53 am

Decided to get an X700. Used it to watch Casino Royale. Wow! It looked phenomenal, especially the intro montage.

I am seeing the same issue where I can only play a single TS file at a time. After that when attempting to play back the file there’s a giant red or green box overlaid on top of the screen. My solution to that has been a smart plug so I can turn it off with an app or with a voice assistant and turn it back on, so it really doesn’t bother me too much. I have confirmed that doing it this way leads to playback working again. Hey, as long as I don’t have to get up and physically unplug a cord, it’s worth it. :lol:

Had no problems with FF/RW. I read this on another forum, it was related to the M9702 but they experienced the same issue with FF/RW.

“ DVDFab 11.x Fastforward and rewind is broken if any Dolby Vision UHD BD is remuxed down to the main movie. They are aware of this bug. Going fastfoward past 2X speed will stop playback.

Please use CloneBD to remux any Dolby Vision UHD BD.
You might be experiencing that bug or..
DVDFab chose the wrong mpls. The main movie Titles without chapters.

Or, it was a bad DVDFab decrypt to clone/copy whole disc. Again, use CloneBD.
I think its a better, free, trustworthy software.”

Just curious if those people having trouble with FF/RW ripped with DVDFab.

Also, I had no issues with streaming Casino Royale from my PC to the X700 via Ethernet. I am sure there will be some films where there may be an issue but with this particular film it was flawless playback. Even paused it a few times and resumed without issue.

All in all I would say the X700 is definitely worth it if you’ve been chasing Dolby Vision for a while and just want a device that can play it back. It’s an incredibly niche use case, but we’re a niche audience!

————

Regarding yusesope’s tool, I honestly think his files are created correctly and he deserves a huge round of applause. I suspect the issue is on the client’s end based on everything that has been reported. Either way, absolutely stunning work on his part and his contributions to this effort of Dolby Vision playback have been immense, so I just wanted to say thank you so much for everything you’ve done and continue to do for us.

built_to_chill
Posts: 36
Joined: Thu Feb 20, 2020 4:45 pm

Re: Dolby Vision now possible through MP4 Mux.

#1461 Post by built_to_chill » Fri Mar 06, 2020 9:25 am

RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
That's interesting. FWIW - and that is probably very little since this is very much "hearsay" - my pro calibrator (who is well qualified and does a lot of stuff for commercial Movie/TV productions as well as consult TV manufacturers) was negative about the implementation of DV in the 2019 SHIELD. We didn't discuss in any detail (because I had decided not to buy one) but I wonder if this is what he was referring to.

built_to_chill
Posts: 36
Joined: Thu Feb 20, 2020 4:45 pm

Re: Dolby Vision now possible through MP4 Mux.

#1462 Post by built_to_chill » Fri Mar 06, 2020 9:34 am

FusionNeo wrote:
Fri Mar 06, 2020 6:53 am
Decided to get an X700. Used it to watch Casino Royale. Wow! It looked phenomenal, especially the intro montage.

I am seeing the same issue where I can only play a single TS file at a time. After that when attempting to play back the file there’s a giant red or green box overlaid on top of the screen. My solution to that has been a smart plug so I can turn it off with an app or with a voice assistant and turn it back on, so it really doesn’t bother me too much. I have confirmed that doing it this way leads to playback working again. Hey, as long as I don’t have to get up and physically unplug a cord, it’s worth it. :lol:

Had no problems with FF/RW. I read this on another forum, it was related to the M9702 but they experienced the same issue with FF/RW.

“ DVDFab 11.x Fastforward and rewind is broken if any Dolby Vision UHD BD is remuxed down to the main movie. They are aware of this bug. Going fastfoward past 2X speed will stop playback.

Please use CloneBD to remux any Dolby Vision UHD BD.
You might be experiencing that bug or..
DVDFab chose the wrong mpls. The main movie Titles without chapters.

Or, it was a bad DVDFab decrypt to clone/copy whole disc. Again, use CloneBD.
I think its a better, free, trustworthy software.”

Just curious if those people having trouble with FF/RW ripped with DVDFab.

Also, I had no issues with streaming Casino Royale from my PC to the X700 via Ethernet. I am sure there will be some films where there may be an issue but with this particular film it was flawless playback. Even paused it a few times and resumed without issue.

All in all I would say the X700 is definitely worth it if you’ve been chasing Dolby Vision for a while and just want a device that can play it back. It’s an incredibly niche use case, but we’re a niche audience!

————

Regarding yusesope’s tool, I honestly think his files are created correctly and he deserves a huge round of applause. I suspect the issue is on the client’s end based on everything that has been reported. Either way, absolutely stunning work on his part and his contributions to this effort of Dolby Vision playback have been immense, so I just wanted to say thank you so much for everything you’ve done and continue to do for us.
Congrats on the X700. Just to say that after the green screen of death, mine only requires powering on/off using the remote (or via CEC after putting TV in standby). Just in case that helps - but I like the smart plug solution :-)

R.e. network playback. I have a Vero 4K which only has 100mbps, and that is able to play every UHD mkv I have flawlessly via network shares. The developers of that product are adamant that gigabit ethernet is not required for lossless UHD rips, and they seem to be correct. However, they have very carefully engineered the cacheing so as to deal with any possible bitrate spike.

Like you I've also noticed that the X700 can play some movies just fine over 100mbps, but there are others which it definitely can not (a recent example for me was Doctor Sleep). I wonder whether there is a way to analytically scan movies in advance (i.e. for average bit rate and peak bit rate) to try to understand what thresholds are ok for X700 network playback. It obviously was never designed for people to play lossless UHDs over DLNA, but perhaps the majority of movies can be left on a NAS. It would be nice to be able to make that decision in advance on a movie by movie basis.

baker99
Posts: 81
Joined: Wed Oct 30, 2019 7:05 pm

Re: Dolby Vision now possible through MP4 Mux.

#1463 Post by baker99 » Fri Mar 06, 2020 9:43 am

RESET_9999 wrote:
Thu Mar 05, 2020 11:25 pm
one more comparison: https://slow.pics/c/TyeCCLDz

no doubt in my mind, it's not identical. at least not from X700 vs Shield
Did you notice a difference between profiles too?

baker99
Posts: 81
Joined: Wed Oct 30, 2019 7:05 pm

Re: Dolby Vision now possible through MP4 Mux.

#1464 Post by baker99 » Fri Mar 06, 2020 9:46 am

RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
Interesting, I wonder if anyone has filed a bug report on the shield forum, maybe it's a simple fix in firmware

baker99
Posts: 81
Joined: Wed Oct 30, 2019 7:05 pm

Re: Dolby Vision now possible through MP4 Mux.

#1465 Post by baker99 » Fri Mar 06, 2020 10:12 am

FusionNeo wrote:
Fri Mar 06, 2020 6:53 am
Decided to get an X700. Used it to watch Casino Royale. Wow! It looked phenomenal, especially the intro montage.

I am seeing the same issue where I can only play a single TS file at a time. After that when attempting to play back the file there’s a giant red or green box overlaid on top of the screen. My solution to that has been a smart plug so I can turn it off with an app or with a voice assistant and turn it back on, so it really doesn’t bother me too much. I have confirmed that doing it this way leads to playback working again. Hey, as long as I don’t have to get up and physically unplug a cord, it’s worth it. :lol:

Had no problems with FF/RW. I read this on another forum, it was related to the M9702 but they experienced the same issue with FF/RW.

“ DVDFab 11.x Fastforward and rewind is broken if any Dolby Vision UHD BD is remuxed down to the main movie. They are aware of this bug. Going fastfoward past 2X speed will stop playback.

Please use CloneBD to remux any Dolby Vision UHD BD.
You might be experiencing that bug or..
DVDFab chose the wrong mpls. The main movie Titles without chapters.

Or, it was a bad DVDFab decrypt to clone/copy whole disc. Again, use CloneBD.
I think its a better, free, trustworthy software.”

Just curious if those people having trouble with FF/RW ripped with DVDFab.

Also, I had no issues with streaming Casino Royale from my PC to the X700 via Ethernet. I am sure there will be some films where there may be an issue but with this particular film it was flawless playback. Even paused it a few times and resumed without issue.

All in all I would say the X700 is definitely worth it if you’ve been chasing Dolby Vision for a while and just want a device that can play it back. It’s an incredibly niche use case, but we’re a niche audience!

————

Regarding yusesope’s tool, I honestly think his files are created correctly and he deserves a huge round of applause. I suspect the issue is on the client’s end based on everything that has been reported. Either way, absolutely stunning work on his part and his contributions to this effort of Dolby Vision playback have been immense, so I just wanted to say thank you so much for everything you’ve done and continue to do for us.
Completely agree, his tool is amazing and to reverse engineer such a complex process is genius.

hepe9
Posts: 71
Joined: Mon Jun 03, 2019 11:04 am

Re: Dolby Vision now possible through MP4 Mux.

#1466 Post by hepe9 » Fri Mar 06, 2020 11:20 am

RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
This is very interesting

C8 and x700 are identical

Shield has the problem

hepe9
Posts: 71
Joined: Mon Jun 03, 2019 11:04 am

Re: Dolby Vision now possible through MP4 Mux.

#1467 Post by hepe9 » Fri Mar 06, 2020 11:29 am

built_to_chill wrote:
Fri Mar 06, 2020 9:25 am
RESET_9999 wrote:
Fri Mar 06, 2020 12:10 am
after more comparisons with my TV internal app and the x700, I now believe the Shield actually output over-saturated color in DV.
I suspect it's because they send a bt2020 rgb 8bit signalwhile the x700 and the appleTV send RGB 8 bit ( no color primaries signaled).

Netflix Stranger Things DV comparisons

Shield vs LG C8 TV: https://slow.pics/c/ah3JaROY

x700 vs LG C8: https://slow.pics/c/Stl6kE9t

x700 vs Shield: https://slow.pics/c/K3bky83X


P-S: before you ask, yes my shield is up to date
That's interesting. FWIW - and that is probably very little since this is very much "hearsay" - my pro calibrator (who is well qualified and does a lot of stuff for commercial Movie/TV productions as well as consult TV manufacturers) was negative about the implementation of DV in the 2019 SHIELD. We didn't discuss in any detail (because I had decided not to buy one) but I wonder if this is what he was referring to.
Maybe I don't understand you because English is not my languague, but you say you know a person who has knowledge in this area, you know what he thinks about DV in Sony TVs? all I have read is that it is more darkness than other manufacturers

RESET_9999
Posts: 506
Joined: Mon Aug 05, 2019 7:12 pm

Re: Dolby Vision now possible through MP4 Mux.

#1468 Post by RESET_9999 » Fri Mar 06, 2020 11:49 am

Arbigator wrote:
Fri Mar 06, 2020 5:26 am

Have you tried setting the Shield's output to YUV 4:2:0 10 bit or YUV 4:2:2 12 bit rather than RGB 8 bit? I could definitely see things looking different if not set to YUV.
My shield is always set to 422 12bits bt2020 HDR10 and DV ready but It doesn't matter in what mode the shield is. DV is always sent in an RGB 8 bit container.

DV in 422 12bit (LLDV) is a mode that was made only for the Sony TV.

DV in a RGB 8 bit container is not better or worse than LLDV. both are the same and both are 12bits.
Please forgive my English.
Sony x700 ----> Denon AVR ----> LG OLED C8
FIX the x700 DT-DL TS bug with this file

codeXRes
Posts: 16
Joined: Mon Jan 20, 2020 1:10 pm

Re: Dolby Vision now possible through MP4 Mux.

#1469 Post by codeXRes » Fri Mar 06, 2020 12:07 pm

hepe9 wrote:
Thu Mar 05, 2020 7:06 pm
@LucasSimba you tried the clips posted for @yusesope?

To see if you have the same results

I tried with the Sony player and the "dvdfab" works but wrongs colors and the other 2 no DV and play in fast speed
I have tried the clips posted by @yusesope on a Sony XF9005; results below.

Plex:

Joker_dvhe.04.06_BL_EL_RPU_Single_Track_Double_Layer.mp4 - DV Logo but over saturated colors (the light bulbs around the mirror are all red).
Joker_dvhe.05.06_BL_RPU_Single_Track_Single_Layer.mp4 - DV Logo but over saturated colors.
Joker_dvhe.07.06_BL_EL_RPU_Single_Track_Double_Layer.mp4 - DV Logo but over saturated colors.
Joker_dvhe.07.06_Double_Track_Double_Layer.mp4 - No DV Logo; played as HDR.


Video Player:

Joker_dvhe.04.06_BL_EL_RPU_Single_Track_Double_Layer.mp4 - No DV Logo; played as HDR.
Joker_dvhe.05.06_BL_RPU_Single_Track_Single_Layer.mp4 - DV Logo but over saturated colors.
Joker_dvhe.07.06_BL_EL_RPU_Single_Track_Double_Layer.mp4 - No DV Logo; played as HDR.
Joker_dvhe.07.06_Double_Track_Double_Layer.mp4 - No DV Logo; played as HDR.

yusesope
Posts: 221
Joined: Sun Jul 28, 2019 3:34 am

Re: Dolby Vision now possible through MP4 Mux.

#1470 Post by yusesope » Fri Mar 06, 2020 12:09 pm

Here are some considerations on the images posted by RESET_9999 (which I continue to thank)

Let's start by looking at the pictures on the PLEX forum (HERE)
Image

The peculiar behavior of the red and blue channels immediately catches the eye. In the Single Layer version, if you look at the region of the histogram lights there is no information relating to the two previous channels with the result that the green color predominates in the image (giving this greenish halo)


Now let's move on to Netflix and RESET_9999 images.
Image
The behavior of blue is almost identical. Green and red (mostly red) tend to shift towards midtones making the image appear "more saturated"

Now let's move on to the X700 which plays a DV Dual Track Dual Layer file and the Shield which instead plays one of my files (dvhe.07.06 Single Track Dual Layer).
Image
Do you notice any similarities with Netflix images?
I see the same behavior as before and in any case totally different from the images on the PLEX forum.

Clearly the analysis is not valid because each test should be carried out with the same camera, the same TV, the same player, etc ... but ... but ...

Different devices give a different "footprint" to the videos they play.
Perhaps what RESET_9999 has noticed is simply the normal behavior of the Shield.

And if Netflix videos are displayed in the same way as mine, then Netflix is ​​also using streams with the wrong colors ... :lol: :lol: :lol:





smartrobot wrote:
Fri Mar 06, 2020 4:35 am
FFMPEG output warnings

Code: Select all

[NULL @ 0x5568201f5c80] Invalid NAL unit 36, skipping.
[NULL @ 0x5568201f6e40] Invalid NAL unit 36, skipping.
yusesope output

Code: Select all

___@little-server:~/src$ python3 bl_el_rpu_builder.py -tbw 4 -bl ~/BL.hevc -el ~/EL.hevc -o ~/Out.hvec
Exception in thread Thread-1:LYSIS: 86.8%     BL_EL_RPU WRITING: 86.0%
Traceback (most recent call last):
  File "/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "bl_el_rpu_builder.py", line 175, in run
    self.read()
  File "bl_el_rpu_builder.py", line 163, in read
    self.get_nal_info(mm,length,global_offset)
  File "bl_el_rpu_builder.py", line 138, in get_nal_info
    nal_type = self.get_nal_type(mmap_obj[(nal_offset + 3):(nal_offset + 5)])
  File "bl_el_rpu_builder.py", line 128, in get_nal_type
    nuh_layer_id = b_stream.read('uint:6')
  File "/home/nick/.local/lib/python3.6/site-packages/bitstring.py", line 3902, in read
    value, self._pos = self._readtoken(name, self._pos, length)
  File "/home/nick/.local/lib/python3.6/site-packages/bitstring.py", line 2016, in _readtoken
    "Tried to read {0} bits when only {1} available.".format(int(length), self.length - pos))
bitstring.ReadError: Reading off the end of the data. Tried to read 6 bits when only 1 available.

Exception in thread Thread-2:LYSIS: 92.4%     BL_EL_RPU WRITING: 91.3%
Traceback (most recent call last):
  File "/usr/lib/python3.6/threading.py", line 916, in _bootstrap_inner
    self.run()
  File "bl_el_rpu_builder.py", line 175, in run
    self.read()
  File "bl_el_rpu_builder.py", line 163, in read
    self.get_nal_info(mm,length,global_offset)
  File "bl_el_rpu_builder.py", line 138, in get_nal_info
    nal_type = self.get_nal_type(mmap_obj[(nal_offset + 3):(nal_offset + 5)])
  File "bl_el_rpu_builder.py", line 128, in get_nal_type
    nuh_layer_id = b_stream.read('uint:6')
  File "~/.local/lib/python3.6/site-packages/bitstring.py", line 3902, in read
    value, self._pos = self._readtoken(name, self._pos, length)
  File "~/.local/lib/python3.6/site-packages/bitstring.py", line 2016, in _readtoken
    "Tried to read {0} bits when only {1} available.".format(int(length), self.length - pos))
bitstring.ReadError: Reading off the end of the data. Tried to read 6 bits when only 1 available.

BL ANALYSIS: 99.3%     EL ANALYSIS: 99.3%     BL_EL_RPU WRITING: 99.3%

There appear to be incorrect NAL units in your stream (as ffmpeg has pointed out to you).
If you analyze a stream like this with my program, you will surely get errors: it is a very simple tool that does not have the ability to handle unexpected errors.
The tool expects to receive a perfect stream ...
Last edited by yusesope on Fri Mar 06, 2020 12:36 pm, edited 2 times in total.

Post Reply