Settings for MakeMKV and VLC to avoid Pixelization

Please post here for issues related to Blu-ray discs
Post Reply
mike_mgoblue
Posts: 146
Joined: Wed Jul 13, 2016 4:36 am

Settings for MakeMKV and VLC to avoid Pixelization

Post by mike_mgoblue »

It has been over six months since I tried ripping a Blu-ray with MakeMKV and watching a video using any type of player such as MPC-BE, MPC-HC, or VLC. I am now using a different computer than I did in the past, because I needed to do a fresh install of Windows 10 Professional on a different computer when my previous laptop broke.

I installed the latest version of MakeMKV. And I am using a newer reinstalled version of VLC. It didn't take me long to realize I had forgotten what some of the best settings were for MakeMKV and VLC.

I initially copied a Blu-ray I own called "Beyond a Reasonable Doubt." When I watched this on MPC-BD, there were no problems. When I watched this on MPC-HC there were no problems. But when I went to MakeMKV and looked under "Preferences," I realized I needed to change some things. For example:

* Under "Video" I changed the "Minimum title length (seconds)" from "120 seconds" to "5 seconds" in order to make sure I didn't miss anything. Is this a good setting?

* Under "Language" I changed "Interface Language" to "English." I also changed "Preferred Language" to "English."

* I left "General" and "IO" and "Protection" and "Integration" alone.

When I went back to look at the "Preference" called "Integration" I saw three boxes that could potentially be checked. I don't remember these boxes being there in the past when I used MakeMKV. The first box said "System." The second box said "System 32." The third box said "VLC."

I then had the feeling that playing the videos I had just copied from the Blu-ray called "Beyond a Reasonable Doubt" would potentially not play well using VLC. Sure enough, all of the video files I copied from "Beyond a Reasonable Doubt" did not play properly with VLC. It was as if there was a green form of pixelization that was intentionally causing problems with the way the encryption/decryption process took place. I tried watching the videos with MPC-BD and MPC-HC and the videos looked fine.

Also, I then used VLC to look at older videos I had ripped using MakeMKV on my other laptop using an older version of MakeMKV. VLC played those older videos I had ripped 100% fine, just as MPC-BD and MPC-HC did. This makes me think it is the current settings I have selected in the newest version of MakeMKV that is causing the problems while ripping the videos from the Blu-ray called "Beyond a Reasonable Doubt."

I then went back to the "Preference" of MakeMKV called "Integration." This time I placed a checkmark in all three boxes called "System, " and "System 32," and "VLC." I ripped all the videos again. But, this did not solve the problem. I still see a pixelated horizontal green line at the top of the videos. This horizontal green line switches back and forth from green to purple. And there are also doubled images in the videos when they play. For example, when a Trailer starts and you see "Rated R," you see two boxes filled with text rather than one.

I then went to VLC and selected the option of "Tools." I then selected "Preferences." I then selected "Input/Codecs." I then changed the top setting of "Hardware-accelerated decoding" from "Automatic" to "Disable." This corrected the video problems when I watched the recently ripped videos from "Beyond a Reasonable Doubt" using VLC. But the part that is very confusing to me is why the "recently" ripped videos did not play correctly when "Automatic" was selected for "Hardware-accelerated decoding," but the the older ripped videos from both Blu-rays and DVDs did play properly - even when "Hardware-accelerated decoding" was selected.

Is there a particular Setting or Preference I need to use in VLC in order to make the copied videos play properly without this pixelization? Or is this pixelization something that is actually placed in the ripped videos by MakeMKV if the checkmark is not selected in the box for "VLC" in the "Integration" form of "Preference"?

Please tell me what Settings and Preferences are good suggested settings for copying Blu-rays in order to make sure no scenes will be left out and to make sure the videos play on all apps - including VLC.

I thank you for your time and help.
Last edited by mike_mgoblue on Wed Apr 03, 2024 3:36 am, edited 1 time in total.
Billycar11
Posts: 3807
Joined: Sun Aug 24, 2014 5:49 am

Re: Settings for MakeMKV and VLC to avoid Pixelization

Post by Billycar11 »

i believe this is a vlc and decoder issue not a makemkv problem i remember hearing bout vlc and some intel igpus just dont get along.
probably nothing you can do maybe new drivers or vlc updates fixed but idk
best just use a program that works on your hardware.
Buy a UHD drive from the guide and how to video maker: https://www.makemkv.com/forum/viewtopic ... 20&t=17831
UHD Drives Guide: https://www.makemkv.com/forum/viewtopic ... 16&t=19634
Auto flash kit $25 Email me for one Billycar5924@gmail.com
dcoke22
Posts: 2613
Joined: Wed Jul 22, 2020 11:25 pm

Re: Settings for MakeMKV and VLC to avoid Pixelization

Post by dcoke22 »

I think your settings for MakeMKV are fine. Personally, I leave preferred language set to None just so things are easier when I rip a foreign language film, but either setting works.

As Billycar11 said, I think the issues with VLC are a problem of how VLC interacts with your GPU.
mike_mgoblue
Posts: 146
Joined: Wed Jul 13, 2016 4:36 am

Re: Settings for MakeMKV and VLC to avoid Pixelization

Post by mike_mgoblue »

Thank you guys.

The previous laptop I used to copy files with MakeMKV was an Intel i5 second gen processor with an external LG Blu-ray drive. The laptop I'm using now to copy files with MakeMKV uses and Intel i5 third gen processor with the same external LG Blu-ray drive.

I can only presume you are likely correct about the Intel GPU causing some of the problems. But, the way VLC experiences these problems with the "New" MakeMKV files made on this third gen Intel i5, but VLC does not experience these problems made with the "Older" MakeMKV files made on the second gen Intent i5 makes me think the Intel third gen i5 is actually causing some of these problems that stay with the files permanently in a way that VLC does not like. Is there merit to that theory?

Also, in the MakeMKV "Preference" called "Integration," what are those three boxes the check marks can be placed in? For example, what happens when you select the boxes as opposed to not selecting the boxes? I'm just wondering because "VLC" is the third box.

Thank you for your time and help.
Post Reply