Process halts when opening Blu ray

Please post here for issues related to Blu-ray discs
Post Reply
Posts: 1
Joined: Wed Nov 15, 2023 9:31 am

Process halts when opening Blu ray

Post by AndreasA »


I've been having some problems when trying to rip LOTR extended edition. MakeMKV sees the blu ray disc and i can start the process of opening it up but it stops at 15% in and just sits still indefinitely, i've let it work for over an hour to try and test if it at some point starts but nothing. I've had this problem to some extent with all of the 6 discs but most of them has finished the opening process by just retrying a lot of times but two of them have been refusing to work at all. i've had other blu rays i've been ripping inbetween tries and they've worked without problems, the disc surface is spotless and no haze is present, i've also tried carefully cleaning the discs with water and dish soap but that wont help either.

Is there anything i can try besides buying a new box set?

Screen dump on how it sits: Image
Posts: 2199
Joined: Wed Jul 22, 2020 11:25 pm

Re: Process halts when opening Blu ray

Post by dcoke22 »

Instead of trying to open the disc, what happens if you make a backup instead? To make a backup, launch MakeMKV, put in a disc, click the icon of a yellow folder with a green arrow pointing into it. Make sure 'decrypt' is checked.
Post Reply