Page 1 of 1

Strange problem after ripping - only half movie converted

Posted: Wed Jan 25, 2017 4:15 am
by Steerpike58
I've been using MakeMKV + Handbrake for some time on Windows with no problems. I'm now trying to convert over to using my MacBook Pro. I hooked up my bluray drive, popped in Star Trek Beyond, and 'backed up' the disk to the local drive with MakeMKV. I then ran handbrake, pointed at the backed up folder, and converted it using high profile. All went well, converted movie played fine, except - something went wrong with subtitles (I intentionally select subtitles b/c my girlfriend is deaf, but for some reason, the subtitles were 'burned in', which I didn't want).

This was probably user error so I figured, no worries, I'll just re-do the handbrake conversion. But for some reason, I could not get handbrake to recognize the ripped folder structure (even though nothing changed). Rebooted, no change. Finally decided to just re-rip the whole thing and see if that made a difference. So ripped the disk again using MakeMKV, and then re-ran the Handbrake conversion. this time, Handbrake saw the ripped folder, and the conversion ran. But this time, every time I tried it (I tried many times!), the conversion completed without any error (approx 1hr) but was literally only half the movie! So then I re-ran handbrake one more time, and this time, pointed back at the ORIGINAL MakeMKV rip and this time, it not only 'saw' the ripped structure without issue, it converted the whole movie perfectly, with subtitles handled the way I want them.

So I'm just perplexed at what could be going on here. This is a very lightly used MacBook Pro, running El Capitan, very little installed software. MakeMKV is latest version, 1.10.4. Handbrake also latest, 1.0.2.

I ran 'beyond compare' against the two rips, and there ARE two differences, one in the largest m2ts file and one in a smaller m2ts file. That itself is, I guess, a sign of trouble (though file sizes were not different). I guess I can do the rip one more time and do a three-way comparison.

Since this is my first exposure to the Mac versions, I'm just not sure what may be going on.

I did do the rip again on my windows box and it ran perfectly.

Thanks for any insight.

Re: Strange problem after ripping - conversion stops half wa

Posted: Wed Jan 25, 2017 4:39 am
by Woodstock
Over on the handbrake forum, you will find out that PGS subtitles (as found on Bluray) cannot be "switchable" in MP4 files. No matter what setting you use, selecting MP4 for the output will burn in the PGS subtitles. MP4 technically only supports text-based subtitles, but there is a popular extension to put DVD subtitles into MP4 files. No such extension exists for PGS.

Select MKV as the output format, and you can have switchable subtitles... But you cannot play it on an AppleTV, because it isn't an MP4 file.

Re: Strange problem after ripping - only half movie converte

Posted: Wed Jan 25, 2017 5:34 am
by Steerpike58
Thanks for the speedy response.

Sorry, I wasn't clear - my output container was already MKV. I play my movies on a variety of devices and I've found MKV is the most reliable.

The subtitles in the second attempt from the first ripped source were 'perfect', so I probably had 'user error' when creating that first conversion. So the issue I'm facing now is that I can't explain why any attempt from the second rip bails out after approx. 50% of the movie, without any error indication. Handbrake looks like it's chugging along normally, showing (eg 50%, 60%, etc) progress, but then next time I look it's done; no error; says 'complete'. But the movie is short by an hour.

At this point, I'm doing a THIRD rip, and will test again with that. If that works, I'll assume something went strangely wrong with that second rip and move on. I'll run compares between rips 1, 2, and 3. I just had to clear out some space so I can carry all these rips!

Re: Strange problem after ripping - only half movie converte

Posted: Wed Jan 25, 2017 5:53 pm
by Steerpike58
Update - a third rip with MakeMKV resulted in files that yielded a flawless handbrake process. A 'beyond compare' comparison of first and third rips showed the files were identical. So somehow, that second rip resulted in files that were slightly different (only by the odd byte, per Beyond Compare). I was using an external (USB) flash drive due to the large size of the rip (43 GB) so maybe that has something to do with it. This could explain why the handbrake process stopped processing halfway through the conversion without error indication.

As for the subtitles - I may indeed have accidentally chosen 'mp4' as the container on one of the early conversion attempts, by switching presets. I forgot that changing presets changes (resets?) container. So that may explain why the subtitles were burned in on one of my tests, as the poster above explained.

Looking into the whole subtitle issue, it seems Handbrake on the Mac is defaulting slightly differently from Handbrake on Windows. In windows, if I simply add all remaining tracks in the subtitle tab, I get all the tracks, with NO checkboxes selected (no 'forced', no 'burn in', etc). But on the Mac, when I do the 'add all remaining tracks' action, The first item (Foreign Audio Scan) has 'forced only' and 'burned in' checked (only that one row; all other rows are unchecked). This may be a good thing; as far as I understand it, checking 'forced only' simply means, only select those subtitles from the source that are marked as 'forced' by the producer, and 'burned in' obviously burns that subtitle track into the image - which may be a bad thing, since if I already have 'english' subtitles selected in my player, I don't think I need to additionally see the subtitles for the foreign bits. Anyway, this is way beyond anything to do with MakeMKV so I'll go off and pursue that on my own!

Re: Strange problem after ripping - only half movie converte

Posted: Sat Feb 11, 2017 7:15 pm
by Steerpike58
I just tried to rip another movie (backup entire bluray to disk (~45 GB), then use handbrake to transcode to an MKV file); and this time, I got a repeat of the problem reported above - the handbrake process ends much earlier than predicted (maybe 30 minutes into what it was predicting as a 1hr 40m job), without any error (tells me the job completed successfully), but the resulting mkv file (movie) ends prematurely at about 30 minutes (movie is almost 2 hrs long). I verified (using VLC) that the 'backup' I created contains a .m2ts file that is the full length movie. When this happened with my first movie (earlier posts in this thread) I put it down to having made some mistake, but now I'm 2 for 2 on having this happen. Same disk converts just fine on my PC.

I guess I'll re-do the entire 'backup' again and see if that cures it. My sense is, the 'backup' process is resulting in a damaged file, somehow. Maybe because I'm using a large USB flash drive ....

Re: Strange problem after ripping - only half movie converte

Posted: Sat Feb 11, 2017 8:46 pm
by Woodstock
When using "Backup", you are depending upon the player to understand the BD structure. If the file structure has issues (such as putting fake titles in that aren't complete), the player has to know how to select the correct play list to get the whole movie.

Using "Open" and saving the feature as an MKV file, MakeMKV will take care of grabbing all the parts of the movie and putting them into the MKV file.