makemkvcon ignoring settings.conf

The place to discuss linux version of MakeMKV
Post Reply
insgs
Posts: 1
Joined: Fri Dec 26, 2014 10:35 pm

makemkvcon ignoring settings.conf

Post by insgs »

Should makemkvcon honour the values in settings.conf? I had to reinstall today in order to get round the 30 day limitation for bluray. I have a purchased key which makemkv is happy with in the gui but makemkvcon was complaining.

The minimum length is set in settings.conf but makemkvcon uses a different value - however it at least can be set on the command line instead. Using strace I can see that makemkvcon is opening settings.conf but it doesn't seem to use it.

Any ideas? Thanks.
NullNix
Posts: 17
Joined: Sat Jan 31, 2015 12:57 pm

Re: makemkvcon ignoring settings.conf, thus does not work at

Post by NullNix »

Note: this bug has successfully dissuaded me from buying MakeMKV. My only use for it is scripted 'makemkvcon backup', but since makemkvcon is ignoring settings.conf of late it is failing to realise that the evaluation key is present, and is permanently failing -- or at least I think that's what's happening. The debug log says:

Debug log started at Sat Jan 31 12:59:23 2015 , written by MakeMKV v1.9.1 linux(x64-release)
Using 524544KB for read cache.
001005:0000 MakeMKV v1.9.1 linux(x64-release) started
001004:0000 Debug logging enabled, log will be saved as /home/nix/MakeMKV_log.txt
005072:0000 Backing up disc into folder "/tmp/raw"
001003:0020 DEBUG: Code 0 at b-!hNPw/-zpyjvHG0<\.:29396851
001003:0020 DEBUG: Code 233 at QeEyYgVpqBRrRXvp7dZmbESI:0
005069:0080 Backup failed
005080:0204 Backup failed.
Application exited at Sat Jan 31 12:59:30 2015

I see no evidence that it will do anything different if the key is a purchased key, which would mean I'd wasted my money. I'm not so rich that I can afford to waste nearly £50 on something that seems likely not to work at all.

(That's another reason I'm skipping buying it -- I'm used to being able to look at the source to figure out the cause of a problem. If no source is available the diagnostics *must* be made correspondingly better, so that people can track problems down sans source. But what do we have here? An opaque 'Code 233' and a totally opaque 'Backup failed' with debugging off. *Why* did it fail? What went wrong? Writing an analogue of strerror() for your program's error codes is not hard...)
NullNix
Posts: 17
Joined: Sat Jan 31, 2015 12:57 pm

Re: makemkvcon ignoring settings.conf, thus does not work at

Post by NullNix »

NullNix wrote:Note: this bug has successfully dissuaded me from buying MakeMKV. My only use for it is scripted 'makemkvcon backup', but since makemkvcon is ignoring settings.conf of late it is failing to realise that the evaluation key is present, and is permanently failing -- or at least I think that's what's happening.
Of course, it is *possible* that this is not an evaluation key problem at all -- but if so, this reinforces my concern that the diagnostics are too bad for makemkvcon to be considered usable at this point.
NullNix
Posts: 17
Joined: Sat Jan 31, 2015 12:57 pm

Re: makemkvcon ignoring settings.conf, thus does not work at

Post by NullNix »

NullNix wrote:Of course, it is *possible* that this is not an evaluation key problem at all -- but if so, this reinforces my concern that the diagnostics are too bad for makemkvcon to be considered usable at this point.
OK, panic over, it's nothing to do with the evaluation key: it's just that this was a DVD and the backup option doesn't work with DVDs. See above re diagnostics really needing improvement... the robot mode is excellent but even that isn't giving useful diagnostics. The exit code is always zero, too, even on error, which is most irritating.

I'll probably buy a copy once I've had a chance to torture it a bit more (a few more blurays to try doing a backup on rather than an mkv extraction via libmmbd).
Post Reply