Speed Control, 1.15.3, and UHD friendly max speed!

Discussion of LibreDrive mode, compatible drives and firmwares
SamuriHL
Posts: 1783
Joined: Mon Jun 14, 2010 5:32 pm

Re: Speed Control, 1.15.3, and UHD friendly max speed!

Post by SamuriHL »

Meh, I doubt it. They all work fine for non U3 discs. One of them is brand new. The other I've had for 2 years. And my ASUS is even older than that. I'm not worried about it.
aboulfad
Posts: 31
Joined: Sat Feb 09, 2019 12:51 pm

Re: Speed Control, 1.15.3, and UHD friendly max speed!

Post by aboulfad »

I wonder if I should set 0=99 for my new Asus BW-16D1HT (ext drive USB3 on Catalina, 1.15.4, LibreDrive 3.10-MK) too ... I did my first UHD 4K DV rip of Black Panther, and it was an abysmal 1X where it took 2'30" to rip.

Ok I followed suit and currently ripped Aquaman UHD at 11x -> 42" :shock: , though at first the sounds the drive was making were kinda un-natural :-D

I wonder about this comment and the sleep bug from this thread about speed control:
"0=99;U1=-;U2=-;U3=-" - Enable unlimited speed for all media, except UHD. For UHD do not issue any speed control commands at all. This setting is for desktop "friendly" drives where changing speed instantly triggers the "sleep" bug for UHD media.
[Oppo UDP-203, ATV 4K] —> Anthem MRX-720 —> LG OLED65E7P
aboulfad
Posts: 31
Joined: Sat Feb 09, 2019 12:51 pm

Re: Speed Control, 1.15.3, and UHD friendly max speed!

Post by aboulfad »

Possible I encountered what Mike warned about encountering the sleep bug with setting max speed. I tried ripping Star Trek 4K 2009, and makemkv was just idling while the drive made sounds as if it's stuck. Sadly I didn't know to enable the debug log, now its on. I recycled the drive and it was fine.

FF to now, ripping WW 2017, and the drive still with U=99, is extracting the main stream (60Gb) at super slow 1x (for very short period of times its goes up to 4x). For the past 1 hour its been ripping at less than 1x ... In a nutshell it seems ripping speed and speed control is a bit indeterministic ? Thx ( & Happy NY)

Here's an excerpt of the log file with some debug code at the top:

Code: Select all

Debug log started at Thu Dec 31 14:29:02 2020 , written by MakeMKV v1.15.4 darwin(x64-release)
Using 262272KB for read cache.
001005:0000 MakeMKV v1.15.4 darwin(x64-release) started
001004:0000 Debug logging enabled, log will be saved as file:///Users/toto/MakeMKV_log.txt
Network access is ENABLED, CURL version 7.64.1/(SecureTransport) LibreSSL/2.8.3 (x86_64-apple-darwin19.0) , proxy server not set.
002010:0000 Optical drive "BD-RE ASUS BW-16D1HT 3.10d" opened in OS access mode.
SDF  v07d: ASUS_BW-16D1HT_3.10_211901041014_KLMJ9NG1716
SDF  v07d: ASUS_BW-16D1HT_3.10_211901041014_KLMJ9NG1716
SDFW: SET_SPEED Asked=5120 Selected=8960 MSV=0x02
001003:0020 DEBUG: Code 100941312 at Hd7!UIYZuj>f?J9[:213139667
001003:0020 DEBUG: Code 100941312 at avK(nb]W1#jplGKp:213130559
SDF  v07d: ASUS_BW-16D1HT_3.10_211901041014_KLMJ9NG1716
001011:0000 Using LibreDrive mode (v06.2 id=0FA242DD4D0B)
SDFW: SET_SPEED Asked=5120 Selected=13568 MSV=0x02
005072:0000 Backing up disc into folder "file:///Users/toto/Movies/backup/WONDER_WOMAN"
005050:0000 Evaluation version, 24 day(s) out of 30 remaining
DEBUG: Code 2147483648 at \@SL/JCy:=H3A/Us:121264786
005085:0000 Loaded content hash table, will verify integrity of M2TS files.
SDFW: SET_SPEED Asked=5120 Selected=13568 MSV=0x02
SDFW: SET_SPEED Asked=101376 Selected=54016 MSV=0x0c
SDFW: SET_SPEED Asked=101376 Selected=54016 MSV=0x0c
SDFW: SET_SPEED Asked=5120 Selected=13568 MSV=0x02
SDFW: SET_SPEED Asked=101376 Selected=54016 MSV=0x0c
SDFW: SET_SPEED Asked=101376 Selected=54016 MSV=0x0c
SDFW: SET_SPEED Asked=101376 Selected=54016 MSV=0x0c
[Oppo UDP-203, ATV 4K] —> Anthem MRX-720 —> LG OLED65E7P
Post Reply