Drive used to work, now just spits out discs (macOS)

Discussion of LibreDrive mode, compatible drives and firmwares
Post Reply
skyzyx
Posts: 10
Joined: Sun Oct 09, 2011 6:42 pm

Drive used to work, now just spits out discs (macOS)

Post by skyzyx »

I have an external ASUS BC-12D2HT in a NexStar enclosure that I successfully patched the firmware for to create a LibreDrive around 18 months ago (I think; quarantine has made all the days run together). I've format-shifted multiple discs from UHD to H.265 using this drive.

Then I didn't do anything with discs for a while. During that time, I upgraded from macOS Mojave → Catalina → Big Sur. Presently I'm running macOS "Big Sur" 11.4. About 6 weeks ago, I tried to format-shift a new disc. The drive spun quietly for about 10-15 seconds, then spit out the disc. Not only is spitting out the disc odd, but the drive didn't sound like you were jamming a metal pipe in the garbage disposal like it used to.

I've tried a variety of 4K discs to no avail, including one that I've successfully format-shifted before. I've tried re-flashing the firmware using /Applications/MakeMKV.app/Contents/MacOS/makemkvcon, which worked without issue (as per viewtopic.php?f=19&t=21863). The drive is connected directly to a 2018 Mac mini Thunderbolt 3 port using a USB-C → USB-B SuperSpeed (3.0) cable.

The movie that I've successfully format-shifted before was purchased from BestBuy and came with both a Blu-ray and UHD Blu-ray disc. Both discs get kicked out after about 10-15 seconds.

Code: Select all

$ /Applications/MakeMKV.app/Contents/MacOS/makemkvcon f --list
Found 1 drives(s)
00: /IOBDServices/6ACD94D0
  ASUS_BC-12D2HT_3.11_211902271319_XXXXXXXXXXX

Code: Select all

$ /Applications/MakeMKV.app/Contents/MacOS/makemkvcon f --drive /IOBDServices/6ACD94D0 --sdf-file ~/Downloads/sdf.bin rawflash main --in ~/Downloads/mk-firmware-pack-20200720/MK/ASUS/BC-12D2HT/ASUS-BC-12D2HT-3.11-WM00300-211902271319.bin

Reading input file ~/Downloads/mk-firmware-pack-20200720/MK/ASUS/BC-12D2HT/ASUS-BC-12D2HT-3.11-WM00300-211902271319.bin
Flashing flags = 0x0 : 0 0 0 0 : ---- ---- ---- ----
Current Drive ID: ASUS_BC-12D2HT_3.11_211902271319_XXXXXXXXXXX
Ready to write drive flash memory.
Type "yes" to continue, "no" to abort
yes
Operation started: Sending flash image to drive
 100% Operation finished
Operation started: Programming flash
 100% Operation finished
Done successfully

Code: Select all

Debug log started at Tue May 18 22:39:30 2021 , written by MakeMKV v1.16.3 darwin(x64-release)
001005:0000 MakeMKV v1.16.3 darwin(x64-release) started
001004:0000 Debug logging enabled, log will be saved as file:///Users/me/MakeMKV_log.txt
Using 262272KB for read cache.
Network access is ENABLED, CURL version 7.64.1/(SecureTransport) LibreSSL/2.8.3 (x86_64-apple-darwin20.0) , proxy server not set.
002010:0000 Optical drive "BD-ROM ASUS BC-12D2HT 3.11d" opened in OS access mode.
SDF  v07e: ASUS_BC-12D2HT_3.11_211902271319_XXXXXXXXXXX
Before I go out and start buying new cables or replacing the drive, is there anything software-related that may be the culprit? I know that the rules around Notarization got stricter in macOS Catalina (which, mike admin, is pretty cheap/easy to do -- as long as you have a Mac). Perhaps since this is attempting to open the disc in "OS access mode", maybe there's something causing an issue?

Any help/direction is appreciated, and I'm not afraid of the Terminal. Thank you.
Billycar11
Posts: 1633
Joined: Sun Aug 24, 2014 5:49 am

Re: Drive used to work, now just spits out discs (macOS)

Post by Billycar11 »

try a dvd or cd and see if it works if so then your bluray laser died.
Buy a UHD drive from the guide and how to video maker: https://www.makemkv.com/forum/viewtopic ... 20&t=17831
UHD Drives Guide: https://www.makemkv.com/forum/viewtopic ... 16&t=19634
Auto self flash kit Email me for one Billycar5924@gmail.com
skyzyx
Posts: 10
Joined: Sun Oct 09, 2011 6:42 pm

Re: Drive used to work, now just spits out discs (macOS)

Post by skyzyx »

  • No 4K UHD (tested several)
  • No Blu-ray (tested several)
  • No DVD
  • No CD
Everything just spins for a moment, then spits the disc back out.

Went ahead and ordered a new ASUS BW-16D1HT, so we'll see how that goes.
OakManor
Posts: 2
Joined: Sun Jun 13, 2021 9:33 pm

Re: Drive used to work, now just spits out discs (macOS)

Post by OakManor »

I have a similar situation where my working LibreDrive flashed enclosure stopped working and just spits out discs.

I have an external OWC Mercury Pro 16X Blu-ray, 16X DVD, 48X CD Read/Write Solution which comes shipped with a LG WH16NS40. When I received it at the end of 2020, I dumped the firmware settings that I could with sdftool and it produced:

Code: Select all

dump_user_HL-DT-ST_BD-RE__WH16NS40_1.04_211901041348_KLIJ8Q83155.tar
I flashed it to

Code: Select all

HL-DT-ST-BD-RE_WH16NS40-NS50-1.05-NM00900-212005061440.bin
It successfully worked across numerous DVDs and Blu-rays for almost half a year. At some point, without ever re-flashing it, the drive stopped reading any type of disc.

If I attempt to power-on the external enclosure with a Blu-ray inside the tray, the drive blinks blue and produces some spinning noises for 55 seconds until it stops spinning and stops blinking any lights. The tray does not automatically eject. This is repeatable and consistent. The OS reports the USB device is connected but MakeMKV reports no usable optical drives.

If I attempt to power-on the external enclosure with a DVD inside the tray, the drive blinks blue and produces some spinning noises for 35 seconds until it stops spinning and stops blinking any lights. The tray does not automatically eject. This is repeatable and consistent. The OS reports the USB device is connected but MakeMKV reports no usable optical drives.

Code: Select all

Mercury Pro Optical:

  Product ID:	0xde2c
  Vendor ID:	0x1e91
  Version:	1.00
  Serial Number:	002933012615
  Speed:	Up to 5 Gb/s
  Manufacturer:	Other World Computing
  Location ID:	0x00700000 / 13
  Current Available (mA):	900
  Current Required (mA):	0
  Extra Operating Current (mA):	0

Code: Select all

MakeMKV v1.16.3 darwin(x64-release) started
The program can't find any usable optical drives.

Code: Select all

» sudo ./sdftool --list
Found 0 drives(s)
If I attempt to power-on the external enclosure with the tray empty, it appears to power on correctly and MakeMKV is able to detect it.

Code: Select all

MakeMKV v1.16.3 darwin(x64-release) started
Optical drive "BD-RE HL-DT-ST BD-RE WH16NS40 1.05d" opened in OS access mode.

Drive Information
Manufacturer: HL-DT-ST
Product: BD-RE WH16NS40
Revision: 1.05
Serial number: KLIJ8Q83155
Firmware date: 2120-05-06 14:40
Bus encryption flags: 17
Highest AACS version: 76

LibreDrive Information
Status: Enabled
Drive platform: MT1959
Firmware type: Patched (microcode access re-enabled)
Firmware version: 1.05
DVD all regions: Yes
BD raw data read: Yes
BD raw metadata read: Yes
Unrestricted read speed: Yes

Disc Information
Disc is being loaded

Code: Select all

» sudo ./sdftool --list
Found 1 drives(s)
DEBUG: code=00000000 src=1@v]~"'&NQRffK@zW.l;."W\Q:29395149
DEBUG: code=00000000 src=1@v]~"'&NQRffK@zW.l;."W\Q:29395149
00: /IOBDServices/D308F1C6
  HL-DT-ST_BD-RE__WH16NS40_1.05_212005061440_KLIJ8Q83155
However, when I only later insert a DVD inside the tray, the drink blinks blue and produces some spinning noises for 30 seconds until it ejects the tray. The same applies if I later insert a Blue-ray inside the tray except that case takes 50 seconds until it ejects the ray. Both are repeatable and consistent.

The only event that I can think of that could have had an impact on this drive would be an OS update from macOS Catalina 10.15.6 to macOS Catalina 10.15.7 (19H1217) but I would expect more users to be complaining of this issue if that were the cause.

What could have gone wrong? Any recommendations other than trashing it and buying a new drive?
Billycar11
Posts: 1633
Joined: Sun Aug 24, 2014 5:49 am

Re: Drive used to work, now just spits out discs (macOS)

Post by Billycar11 »

OakManor wrote:
Mon Jun 14, 2021 12:03 am
I have a similar situation where my working LibreDrive flashed enclosure stopped working and just spits out discs.

I have an external OWC Mercury Pro 16X Blu-ray, 16X DVD, 48X CD Read/Write Solution which comes shipped with a LG WH16NS40. When I received it at the end of 2020, I dumped the firmware settings that I could with sdftool and it produced:

Code: Select all

dump_user_HL-DT-ST_BD-RE__WH16NS40_1.04_211901041348_KLIJ8Q83155.tar
I flashed it to

Code: Select all

HL-DT-ST-BD-RE_WH16NS40-NS50-1.05-NM00900-212005061440.bin
It successfully worked across numerous DVDs and Blu-rays for almost half a year. At some point, without ever re-flashing it, the drive stopped reading any type of disc.

If I attempt to power-on the external enclosure with a Blu-ray inside the tray, the drive blinks blue and produces some spinning noises for 55 seconds until it stops spinning and stops blinking any lights. The tray does not automatically eject. This is repeatable and consistent. The OS reports the USB device is connected but MakeMKV reports no usable optical drives.

If I attempt to power-on the external enclosure with a DVD inside the tray, the drive blinks blue and produces some spinning noises for 35 seconds until it stops spinning and stops blinking any lights. The tray does not automatically eject. This is repeatable and consistent. The OS reports the USB device is connected but MakeMKV reports no usable optical drives.

Code: Select all

Mercury Pro Optical:

  Product ID:	0xde2c
  Vendor ID:	0x1e91
  Version:	1.00
  Serial Number:	002933012615
  Speed:	Up to 5 Gb/s
  Manufacturer:	Other World Computing
  Location ID:	0x00700000 / 13
  Current Available (mA):	900
  Current Required (mA):	0
  Extra Operating Current (mA):	0

Code: Select all

MakeMKV v1.16.3 darwin(x64-release) started
The program can't find any usable optical drives.

Code: Select all

» sudo ./sdftool --list
Found 0 drives(s)
If I attempt to power-on the external enclosure with the tray empty, it appears to power on correctly and MakeMKV is able to detect it.

Code: Select all

MakeMKV v1.16.3 darwin(x64-release) started
Optical drive "BD-RE HL-DT-ST BD-RE WH16NS40 1.05d" opened in OS access mode.

Drive Information
Manufacturer: HL-DT-ST
Product: BD-RE WH16NS40
Revision: 1.05
Serial number: KLIJ8Q83155
Firmware date: 2120-05-06 14:40
Bus encryption flags: 17
Highest AACS version: 76

LibreDrive Information
Status: Enabled
Drive platform: MT1959
Firmware type: Patched (microcode access re-enabled)
Firmware version: 1.05
DVD all regions: Yes
BD raw data read: Yes
BD raw metadata read: Yes
Unrestricted read speed: Yes

Disc Information
Disc is being loaded

Code: Select all

» sudo ./sdftool --list
Found 1 drives(s)
DEBUG: code=00000000 src=1@v]~"'&NQRffK@zW.l;."W\Q:29395149
DEBUG: code=00000000 src=1@v]~"'&NQRffK@zW.l;."W\Q:29395149
00: /IOBDServices/D308F1C6
  HL-DT-ST_BD-RE__WH16NS40_1.05_212005061440_KLIJ8Q83155
However, when I only later insert a DVD inside the tray, the drink blinks blue and produces some spinning noises for 30 seconds until it ejects the tray. The same applies if I later insert a Blue-ray inside the tray except that case takes 50 seconds until it ejects the ray. Both are repeatable and consistent.

The only event that I can think of that could have had an impact on this drive would be an OS update from macOS Catalina 10.15.6 to macOS Catalina 10.15.7 (19H1217) but I would expect more users to be complaining of this issue if that were the cause.

What could have gone wrong? Any recommendations other than trashing it and buying a new drive?
Clean the disc
Try different discs
Clean the drive
Get BU40N
Buy a UHD drive from the guide and how to video maker: https://www.makemkv.com/forum/viewtopic ... 20&t=17831
UHD Drives Guide: https://www.makemkv.com/forum/viewtopic ... 16&t=19634
Auto self flash kit Email me for one Billycar5924@gmail.com
Post Reply