Botched ASUS-BC12D2HT 1.00 firmware update

Forum for discussions about UHD-capable dives
Post Reply
Posts: 1
Joined: Tue Jun 04, 2019 4:54 pm

Botched ASUS-BC12D2HT 1.00 firmware update

Post by naddy »

Let me just preface this by saying I should've read more carefully yada yada. I did not make a backup of the firmware. i did not check if my SATA mode was in AHCI or IDE mode (turns out it only has AHCI) and I didn't even check the manufacture date to make sure it wasnt pre 2015.
So it's all my fault, don't worry about it, I know.

Aaanyway, I downloaded the FW Changer + UHD friendly firwmares from here: ... 16&t=18933

Then I ran the flasher, picked the DE_ASUS_BC-12D2HT_3.00.bin firmware, it ejected the tray, error #4 came up and that's pretty much it. After reboot the firmware on the drive is just "BOOT" and I can't close the tray or anything. The light on it never flashes. It never makes any sound.

Prior to starting the firmware was 1.00. Manufacture date is 2015 05 20.

So to try and fix this, I first hooked the drive up to an old laptop of mine that can use SATA in IDE mode, and ran some kind of Windows 7 pen edition on there, and I tried various flashers such as this one: and the Dosflasher32 thing that was bundled with the Win7 PE.
I paired these flashers with various flash files I found around here on the forums, such as MK, the DE (that failed before) and an allegedly clean 3.00 I found. But nothing seems to help, the flashers either error right away or hangs at 0%.

So should I just order a new drive or can I rescue this? I'm thinking maybe a low-level flasher (that runs in DOS maybe?) and a clean 1.00 could fix this, but I have neither.


EDIT: So the drive is kind of back to life. I managed to get ASUS-BW-16D1HT-3.10-WM01601-211901041014 flashed to it after a couple of tries with DosFlash32. I went with that version because I read somewhere around here I should go with that first and then downgrade to whatever version I want.
So the drive shows up in MakeMKV and all now as a "16D1HT" but it doesnt read any disc.
Posts: 705
Joined: Tue Mar 06, 2018 11:38 pm

Re: Botched ASUS-BC12D2HT 1.00 firmware update

Post by st4evr »

That's because the current firmware versions from these newer generation drives (the MK and DE versions discussed in this forum) are NOT compatible with the hardware of the older, previous generation drives in all cases. Period.

The incompatibility is at the hardware level. The new firmware requires the newer hardware to work. You said you did your reading now, well.. doesn't sound like it because this is clearly discussed here, for that exact same drive: ... 2HT#p74214

Alongside with your current options. Which in most cases it will be more of a headache than anything else, so the easiest solution will be to purchase a proper, new drive for UHD support. ... 16&t=19634
Last edited by st4evr on Thu Jun 13, 2019 9:29 pm, edited 1 time in total.
Posts: 1636
Joined: Sun Aug 24, 2014 5:49 am

Re: Botched ASUS-BC12D2HT 1.00 firmware update

Post by Billycar11 »

when it was in boot mode it was likely savable just by going to to asus's website and downloading the firmware for your drive.
but not that your drive thinks it a newer hardware revision and its not you will not be able to downgrade with the asus or lg unlocked flashers.
the drive is probably no longer recoverable if you did not use the data mover or backup your original firmware because if you flashed the 3.10mk clean without merging your cal data its a brick
and that advise you read is from me and was only for newer firmware like lg 1.04 asus 3.10 and 3.11 not asus 1.00 that kills it if you don't backup also asus 3.10mk kills dos flash so yeah probably a permeant brick
Buy a UHD drive from the guide and how to video maker: ... 20&t=17831
UHD Drives Guide: ... 16&t=19634
Auto self flash kit Email me for one
Post Reply