Star Wars The Last Jedi 4K - PSA

Please post here for issues related to UHD discs
Post Reply
monkeymindboy
Posts: 27
Joined: Sat Apr 07, 2018 12:35 pm

Star Wars The Last Jedi 4K - PSA

Post by monkeymindboy »

If anyone else is running into an issue with The Last Jedi 4K disc errors, I found a tip from Chris Kelly over in the LibreDrive forum.

I have two drives, one LG WH16NS40, and the other ASUS BW-16D1HT, and both were flashed to WH16NS60 1.00. I haven't had any problems for a longtime with both drives flashed this way. I took out my copy of The Last Jedi that I purchased back in March of 2018 from Best Buy to make a new MKV copy with 1.15.3 to get both Dolby Vision and Atmos. The movie failed over and aver again in both drives, and just to rule out the disc, I went out and bought a new copy today at Best Buy. Same error in both drives. The main file 00018.m2ts kept failing to copy about halfway through when trying to perform a backup or making an MKV from the disc. I saw Chris's post and re-flashed the ASUS drive back to 3.10 and I was successfully able to make a backup of the disc.
Windows 10 Pro
LG WH16NS40 - UHD Friendly
Asus BW-16D1HT - UHD Friendly
LG WH16NS40 - External Drive - Blu-Ray
HD/DVD - XBOX360 - External Drive
Trickyd-1
Posts: 83
Joined: Sat Dec 30, 2017 12:51 am
Location: UK

Re: Star Wars The Last Jedi 4K - PSA

Post by Trickyd-1 »

Sounds about right. Personally I’ve Have had a few discs recently that wouldn’t read with NS60 FW including The Shining, BTTF 1&2 and then a few that would only read with NS60 FW including BTTF3 but then many others that worked with any firmware.
Post Reply