Recovering from read errors in Linux

Discussion of advanced MakeMKV functionality, expert mode, conversion profiles
Posts: 18
Joined: Mon Mar 23, 2015 9:52 pm

Re: Recovering from read errors in Linux

Post by MrVanx »

Rojma wrote:
Mon Jun 29, 2020 3:28 pm
I strongly recommend you only use isoprophl alcohol to clean the disc. For me using alcohol has resolved almost all read issues I have had with disc read issues. Using other methods suggested around the interwebs, such as liquid hand soap, has actually led to more problems for me.
Yes ive got some 99% isopropyl on its way and some microfibre cloths, I wont let this disc beat me :D

Any tips on how to apply it or just dab onto a cloth?
Posts: 8156
Joined: Sun Jul 24, 2011 11:21 pm

Re: Recovering from read errors in Linux

Post by Woodstock »

From the "if you are experiencing errors" topic in the BD section:
Proper disc cleaning:

Center to edge, never circular.

How to clean CD/DVD/Blu-ray disks
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Posts: 18
Joined: Mon Mar 23, 2015 9:52 pm

Re: Recovering from read errors in Linux

Post by MrVanx »

Just a quick update (in case it is helpful for others), Ive been re-running step 2 but I increased the number of retries to 2 or more (i'm working on 4 at the moment) and the bad-sector size is reducing slowly every time which is great.

This is the line I use (for reference):

Code: Select all

ddrescue -d -r4 -b2048 /dev/sr0 brimage mapfile
The initial run of step 2 gave me a bad-sector size of 1507KB, I'm now down to 1089KB (the number of bad-areas goes up as explained in the ddrescue manual) I don't think this is important but I eject the disc, close the terminal, put the disc back in and restart a new terminal session each time.

I had another go copying over the files and using the .dat file generated by a non-decrypted backup attempt but the hash check shows up corrupted files again and the title I want to get is still missing from the makemkv screen. I will persist onwards a while longer with ddrescue (It sounds like several days is totally normal for a dodgy disc).
Posts: 18
Joined: Mon Mar 23, 2015 9:52 pm

Re: Recovering from read errors in Linux

Post by MrVanx »

OK TLDR: I succeeded in rescuing the disc!

Long version:
ddrescue zoomed through the remaining 1100 or so Kb on the last attempt a couple of days ago so I thought "Wow!". I ran through the remaining steps and unfortunately makemkv was still unable to rip the titles I needed from this one so I gave up temporarily.

The isopropyl didnt seem to make any difference but I will still use it to clean any discs that I have trouble with later.

My suspicion is that the drive didn't kick up a read error but instead gave garbage data (hence the ton of hash check errors in makemkv?), I kicked myself for not making a backup of the mapfile before I ran that last rescue.

For my linux machine I had actually installed ddrescue-gui so I ran that up with the intention of doing another rescue attempt (from the start), I noticed several presets in the of which reduced the block read size and was labelled "best recovery" so I ran the disc up with that setting and the whole disc was rescued in just under 40m!?!?! (the previous rescue would take ~16hr).

The next step I took was out of necessity rather than anything else, I am running out of HDD space so instead of copying over the BDMV folder to the location of the .dat file I placed soft links to the three top level folders in the mounted disc image (the image just freshly rescued) so I didnt take up the space.

I ran up makemkv via the dat file and VOILA!!! :D Needless to say im a happy chappy, apologies for the thread hijack but I assume this info will be useful for someone down the line, I will be backing the rescue image, dat file and everything else somewhere safe should I need it again!

I have another disc I haven't been able to rip for ages so I will attempt the same process with that one.

Cheers all!
Posts: 56
Joined: Tue Nov 10, 2015 3:11 am

Re: Recovering from read errors in Linux

Post by xr200 »

lepathi wrote:
Fri Jun 19, 2020 12:30 pm
Doing this I was able to create an Image of Alita: Battle Angel with "only" 70MB corrupt sectors.

Yet, I am unable to rip the movie with makeMKV due to 342 'HashCheck Errors". Did anybody experience similar and/or has a workaround for me to get that movie ripped?
I'm experiencing the same problem with a different BD. I followed the instructions to the letter, but when I ran makemkv, I got a "hashcheck error".
Just reporting that it's not just you, no suggestions on what to do about it.
Post Reply