AV synchronization issues on almost every UHD disc?

Everything related to MakeMKV
sofakng
Posts: 26
Joined: Fri Mar 19, 2010 12:51 pm

AV synchronization issues on almost every UHD disc?

Post by sofakng »

I've been using MakeMKV 1.15.3 and a brand new LH WH16NS40 (flashed to WH16NS60 1.02MK firmware). I've been getting lots of AV synchronization issues and I've just installed MakeMKV 1.15.4 and it's still happening. However, instead of multiple AV synchronization issue messages during the ripping, I only see one message at the end:

Code: Select all

Saving 1 titles into directory //redacted/storage_media/video/Bluray UHD/Coco (2017)
AV synchronization issues were found in file 'Coco (2017).mkv' (title #4)
Forced subtitles track #9 turned out to be empty and was removed from output file
1 titles saved
Is anybody else having these issues?

Here is the drive information from MakeMKV:

Code: Select all

Drive Information
OS device name: F:
Current profile: BD-ROM
Manufacturer: HL-DT-ST
Product: BD-RE WH16NS60
Revision: 1.02
Serial number: REDACTED
Firmware date: 2118-10-29 19:36
Bus encryption flags: 17
Highest AACS version: 76

LibreDrive Information
Status: Enabled
Drive platform: MT1959
Firmware type: Patched (microcode access re-enabled)
Firmware version: 1.02
DVD all regions: Yes
BD raw data read: Yes
BD raw metadata read: Yes
Unrestricted read speed: Yes
Woodstock
Posts: 8044
Joined: Sun Jul 24, 2011 11:21 pm

Re: AV synchronization issues on almost every UHD disc?

Post by Woodstock »

That is a bug - whenever the "forced subtitle track was empty" message is displayed, the AV sync message precedes it. Real AV sync messages will tell you where the error was.

Hopefully Mike remembered to fix that in 1.15.4, but I haven't checked it.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
sofakng
Posts: 26
Joined: Fri Mar 19, 2010 12:51 pm

Re: AV synchronization issues on almost every UHD disc?

Post by sofakng »

Oh, interesting ...

That error log I posted IS from v1.15.4.

With the previous version (1.15.3), I would get lots of AV synchronization errors with times and frame drop counts, etc.

With the new version (1.15.4), I'm just seeing that one message at the end like I posted.
Woodstock
Posts: 8044
Joined: Sun Jul 24, 2011 11:21 pm

Re: AV synchronization issues on almost every UHD disc?

Post by Woodstock »

oh, MIKE....
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
sofakng
Posts: 26
Joined: Fri Mar 19, 2010 12:51 pm

Re: AV synchronization issues on almost every UHD disc?

Post by sofakng »

Can I ignore the message or does it cause any potential problems?
Woodstock
Posts: 8044
Joined: Sun Jul 24, 2011 11:21 pm

Re: AV synchronization issues on almost every UHD disc?

Post by Woodstock »

Yes, ignore it. It's an informational message most of the time anyway. Unless you're dealing with Atmos... And it only means something if a track and location are present.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Legenista
Posts: 37
Joined: Tue May 09, 2017 12:50 am

Re: AV synchronization issues on almost every UHD disc?

Post by Legenista »

Even if this is a false alert for 90% of titles, it's also a problem.

Why? I'll explain: When I ripped BTTF part I which has the Atmos track, there was no way to fix this. Apparently the only solution was to let all other tracks in the MKV file, including the DD 5.1 derived from Atmos. If I do that I don't see the audio dropout bug.

However BTTF part II I ripped twice and the first time (note: also has the same A/V SYNC ISSUE warning) I noticed a very quick freezing in a specific moment of the movie (less than 500 ms for sure). The 2nd time I didn't notice. The Atmos track is still there.

That doesn't mean:

- MAKEMKV isn't damaging the end result in any way;
Or
- The disc isn't flawed/defective, which may explain why MAKEMKV says A/V SYNC ISSUE. The disc could be messed somehow.

For BTTF part I thought this was a false alert, after reading posts from here.

Did you know how I discover this was not the case?

Not by watching almost 2 hours from the movie, and 120 minutes for each track, and noticing if there was something wrong.

I discovered there was something wrong only if the Atmos track was there in an unusual way:

- By splitting the 4K MKV file into 15200 MB parts, using MKVTOOLNIX, to put these splitted parts in Google Drive free accounts.

So I opened part 4 and right at the first seconds there was audio dropout. And there was image freezing lot longer than 0.5 second. In fact, SECONDS.

This bizarre bug affected the video as well, as if the Atmos was a virus damaging anything in its path.

If I hadn't opened the files I would never had spot any of this in the 1st place.

So, when we read things like that:

*********
Yes, ignore it. It's an informational message most of the time anyway. Unless you're dealing with Atmos... And it only means something if a track and location are present.
*********

We assume everything will be fine... until we check if MAKEMKV's warnings hold any water.

Also, from the looks of it this is not an Atmos bug:

Sat Dec 14, 2019 from here:
viewtopic.php?f=8&t=21079

Says:

*********
I've seen these issues come in with UHD rips as well in the last few days, and in all cases none of the rips have included an Atmos track. They've been DTS-HD, and the Blu-Rays I have tested have all been DTS. I'll be sure to test some Dolby back-ups today.
*********

So, to sum things up:

- All these discs can't be defective. What are the odds?

In my case all MAKEMKV use is done with the folders from 4K/BD already decrypted and stored in my SSD.

Logic then tells me this is MAKEMKV's fault, which is not doing what needs to do properly, perhaps due to some inconsistency in certain titles, which trigger these warnings and result in a few cases broken tracks that may or may not affect the video as well.

Unless this bug is fixed then we can never trust the MKV rips we get again.

****************

EDIT:

I just saw Mike has released a new MAKEMKV version:

**********
MakeMKV v1.15.4 (8.12.2020 )
Improved handling for discs with mastering errors
Many internal improvements and small bugfixes
Implemented seamless joining of TrueHD streams with overlapping frames based on Dominik Mydlil's idea
MakeMKV now recognizes and converts double-track Dolby Vision MKV files
Bug fixes:
Program could fail when processing TrueHD streams from MKV file
DTS core was not extracted from DTS-HD streams (1.15.0 regression)
**********

I am going to verify if it changes anything here, and let you know the results if not today, in the next days.

What I said earlier is that if we don't know if the file has been affected, it is difficult to analyze thoroughly. MAKEMKV just saying it has A/V SYNC ISSUES and us taking hours to really make sure these are not there is not practical. I am used to rip my discs and only later go back to the files.
ghost rider
Posts: 73
Joined: Fri Jan 05, 2018 11:30 pm

Re: AV synchronization issues on almost every UHD disc?

Post by ghost rider »

This sheds a little light on what I've been experiencing. I don't know about anyone else but I'm getting tired of watching return of the jedi. All of my equipment is in another room so everyone else may already know this but when I get audio drop out or mute my AVP looses its sync on the atmos audio.

I don't know why but a year ago when I bought makemkv it worked perfectly on every UHD disc I bought. Now with LOTR and Star wars sagas some play fine and other have dozen or more of these drop outs. Making it even harder I don't know for sure if its my Oppo udp 203.

I wish there was a better way to determine whether your disc is bad or its a bug in makemkv.
Legenista
Posts: 37
Joined: Tue May 09, 2017 12:50 am

Re: AV synchronization issues on almost every UHD disc?

Post by Legenista »

ghost rider wrote:
Wed Dec 23, 2020 1:44 am
This sheds a little light on what I've been experiencing. I don't know about anyone else but I'm getting tired of watching return of the jedi. All of my equipment is in another room so everyone else may already know this but when I get audio drop out or mute my AVP looses its sync on the atmos audio.

I don't know why but a year ago when I bought makemkv it worked perfectly on every UHD disc I bought. Now with LOTR and Star wars sagas some play fine and other have dozen or more of these drop outs. Making it even harder I don't know for sure if its my Oppo udp 203.

I wish there was a better way to determine whether your disc is bad or its a bug in makemkv.
This IS MAKEMKV's doing, no question about it. If this was somehow a flaw in the disc you would have spot it right after watching without any MKV conversion.

The fact MAKEMKV is saying A/V sync issues even for DVDs, such as Brazil (1985) 3-DVD CRITERION edition, makes me wonder how many titles it is messing with and for how many this is only a warning, and nothing is broken within the generated files.

I can't check every single file and every single audio track, this could take ages and there's always the possibility the bug could only be evidenced after splitting with a software such as MKVTOOLNIx. I find hard to believe multiple discs are damaged or flawed for say, the first X units, and MAKEMKV is doing everything fine.

The last release said all of this in the changelog:

*********
Improved handling for discs with mastering errors
Many internal improvements and small bugfixes
Implemented seamless joining of TrueHD streams with overlapping frames based on Dominik Mydlil's idea
MakeMKV now recognizes and converts double-track Dolby Vision MKV files
Bug fixes:
Program could fail when processing TrueHD streams from MKV file
DTS core was not extracted from DTS-HD streams (1.15.0 regression)
*********

What improvements are there when recent rips are still having a major bug that apparently affects Dolby Atmos tracks, which are always there in most UHD discs?

At least put some stick thread explaining what kind of bug this is, one that is so slick that resist being fixed by developers and no one can tell what really causes it or how it is affecting these different titles.

So far I noticed audio dropout and very quick freezing in a specific scene from BTTF part 2. If this is only affecting Atmos tracks I can't say, yet this can't be the only problem because if that were the case then the video would never be affected at the same time.

If you have a broken audio stream that doesn't mean the video will be damaged as well.

A/V sync issue as the term implies is not AUDIO SYNC ISSUE, the "V" there also includes the video.

That's what is really strange, why would the video be having an issue, too?

And then I rip BTTF part 2 again, and the problem isn't there in the exact same moment/scene it was before.

So what is going on, really? Maybe it has to do with the SSD drive not being fast enough, so MAKEMKV created a flawed MKV that looks like it was recorded in an area of the drive that had a bad block, so CRC error?

As for BTTF part 1, no matter how many times I try to rip, the problem will ALWAYS be there. And it can freeze the video as well, in the same area the Atmos track has an audio dropout, if I split into 15 GB parts the 60-70 GB video from the movie, and then check part 4.

But, in this case (BTTF part 1) the problem vanishes if I remove the Atmos track from the rip (MKV). So for BTTF part 1 I am forced to only put inside the MKV the DD 5.1 track derived from Atmos.

Oddly if I keep the Atmos for BTTF part 2, so far I am not seeing any issue, even if I split into 15 GB parts this 4K title. That doesn't mean there couldn't be sync/freezing issues with the file. I am just not seeing any of it there... yet.

For all 3 BTTF movies the warning was given by MAKEMKV. So this could mean all of them (part 1 was confirmed...) could present a problem if the Atmos track is present.

******************
I realize these movies give the admin a hard time, also the many protections and ways these discs are authored make a lot harder to get things straight, even so at least please clarify what's happening.

I've been using MAKEMKV for years and never had a single issue, until now. And it had to be with my favorite movies, the BTTF trilogy. :cry:
ghost rider
Posts: 73
Joined: Fri Jan 05, 2018 11:30 pm

Re: AV synchronization issues on almost every UHD disc?

Post by ghost rider »

For me and the few UHD movies I have only the star wars have caused me issues. I'm convinced it's my Marantz av 7702 loosing and regaining it's lock on the Atmos. As I work through the movies I'm up to force awakens and it had only one hiccup. I can live with that. As you said it would be nice if this bug would be recognized and when it is fix I can redo the mkv files. I'm not going to even try until then. It will be a few years before I watch any of these again.
Woodstock
Posts: 8044
Joined: Sun Jul 24, 2011 11:21 pm

Re: AV synchronization issues on almost every UHD disc?

Post by Woodstock »

Example where sync message is actually because of audio sync issues:

Code: Select all

AV synchronization issues were found in file 'Z:/Inukami!/Inukami! HD01-14.mkv' (title #1)
AV sync issue in stream 1 at 1:33:44.083 with duration of 1.341ms : audio gap was filled with silence
AV sync issue in stream 1 at 3:30:53.939 with duration of 1.341ms : audio gap was filled with silence
AV sync issue in stream 1 at 4:17:46.015 with duration of 1.337ms : audio gap was filled with silence
AV sync issue in stream 1 at 5:04:38.091 with duration of 1.333ms : audio gap was filled with silence
In this case, because the publisher stuffed 14 episodes into one play list.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Legenista
Posts: 37
Joined: Tue May 09, 2017 12:50 am

Re: AV synchronization issues on almost every UHD disc?

Post by Legenista »

I was just checking a MKV I created in 2019 from Karate Kid (1984) UHD/4K. This one has as first track Dolby Atmos, and then DD 5.1 derived from it (MAKEMKV saves the MKV file with both). It also has other english tracks, as described here:

http://dvdcompare.net/comparisons/film.php?fid=50362

Since I splitted this with MKVTOOLNIX's help into 15 GB parts, to put them in Google Drive free accounts, I was able to store the 64 GB file I had here.

I downloaded the whole thing today. Then I checked part 4 (file) of 5.

I noticed right in the first seconds a very quick audio dropout, at the 1st second into this file. This one is very subtle, but it's there. You don't notice such audio dropout watching the movie (I mean the 64 GB file, not splitted) in the same scene, at 1h27m36s.

But you notice the audio dropout at second 1 from file 4 of 5, splitted into 15 GB parts.

So this means MKVTOOLNIX did something wrong, right?

Well, no. If I select the DD 5.1 derived track from Atmos the audio dropout WILL NOT BE THERE in this file 4 of 5. It will not be there at the 1st second.

So it's possible if I rip this Karate Kid (1984) UHD/4K disc I'll see the A/V SYNC ISSUE warning again. I don't remember if MAKEMKV said this to me at the time, but since all UHDs with Atmos are having the same technical problem, then it's very likely it will say the same to me.

Splitting with MKVToolnix's help didn't change anything in the original 64 GB file. When I append the 5 parts I am reconstructing the entire content that still remain to be lossless, as it was before the splitting.

The fact MKVTOOLNIX evidences the bug with the Atmos tracks only after splitting doesn't mean it's MKVTOOLNIX that is breaking the Atmos track. It means the track itself was poisoned when MAKEMKV created the MKV based on the 4K/UHD decrypted folders.

This can't be MKVTOOLNIX's fault because it is happening with different titles from different distributors. KARATE KID, for example, was released by Sony. BTTF is from Universal.
preserve
Posts: 711
Joined: Sun Sep 13, 2015 10:21 pm
Location: Canada

Re: AV synchronization issues on almost every UHD disc?

Post by preserve »

^ I'm not sure what your goal is with these long stories that are filled with completely unrelated details. Why are you looking back to a rip you made in 2019? We already know that MakeMKV's previous approach for Atmos could have issues on some titles.

You should make a new rip with 1.15.4 and if you encounter an issue, you should post a thread for that specific title in the correct disc subforum, along with a log of what occurred. That is the way that issues can be investigated and resolved.
Using: ASUS BW-16D1HT 3.00
Legenista
Posts: 37
Joined: Tue May 09, 2017 12:50 am

Re: AV synchronization issues on almost every UHD disc?

Post by Legenista »

preserve wrote:
Mon Dec 28, 2020 10:21 am
^ I'm not sure what your goal is with these long stories that are filled with completely unrelated details. Why are you looking back to a rip you made in 2019? We already know that MakeMKV's previous approach for Atmos could have issues on some titles.

You should make a new rip with 1.15.4 and if you encounter an issue, you should post a thread for that specific title in the correct disc subforum, along with a log of what occurred. That is the way that issues can be investigated and resolved.
What I am trying to tell here is that every single 4K title has been showing the same warning. This is either nothing for most of them or it could mean exactly what I am telling you, which is MAKEMKV creating a problem where there is none.

This is a log from another disc I tried today, and yes, this was done with the last version:

https://pastebin.com/dsp3zP1a

Ghostbusters (1984). This seems to be a recurring issue. I have yet to find a UHD disc that MAKEMKV doesn't issue any warning. And yeah, this one also has Dolby Atmos.

In fact most 4Ks have this track, so this isn't something only few have.

What kind of bug this is anyway, that is so widespread?

You do realize that if this means multiple rips defective we can never trust MAKEMKV again? Do you? Because in order to check if the rip has any flaw it would take quite some time.

Another possibility is that splitting these rips with MKVTOOLNIX creates this kind of issue:
http://forum.doom9.org/showpost.php?p=1 ... tcount=934

So in theory MKVTOOLNIX should have set the same policy as it did with FLACs:
https://gitlab.com/mbunkus/mkvtoolnix/- ... -supported

Yet I doubt very much this isn't MAKEMKV's doing.
preserve
Posts: 711
Joined: Sun Sep 13, 2015 10:21 pm
Location: Canada

Re: AV synchronization issues on almost every UHD disc?

Post by preserve »

Legenista wrote:
Tue Dec 29, 2020 1:43 am
What kind of bug this is anyway, that is so widespread?
If you're talking about the false AV Sync message appearing when forced subtitles are removed, that has already been confirmed as a bug and a false message, as reiterated in this thread. If you're talking about the possible AV Sync error occurring at 0:00:00, then yes, this seems to be a relatively recent new type of error, and we'll have to wait for more info from Mike or a new version to address what the issue may be. Neither of these issues demand the "sky is falling" drama that you're trying to create.
Using: ASUS BW-16D1HT 3.00
Post Reply