MakeMKV 1.14.1 doesn't see network drives on Win10

Everything related to MakeMKV
Post Reply
Mathman85
Posts: 2
Joined: Mon Nov 12, 2018 10:41 pm

MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Mathman85 »

Hello! I just updated to 1.14.1, and now the software does not recognize any of my network drives that I use for storage. It says my default location doesn't exist, but the drive is mapped and shows up in Windows Explorer; it also doesn't show any network locations if I browse to the folder I want to save the files in.

Since I use my NAS for media storage, this has created an inconvenience. Is this problem unique to me or is anybody else experiencing the same?
Woodstock
Posts: 8613
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock »

Do you access the NAS as a "shared drive" resource (mount it as a drive letter) or use direct network addressing, such as \\nas\rawvid ?

All of my ripping is done to a NAS (Synology), and 1.14.x has worked for that, but I map the raw video as drive Z: on all my machines. I'd have to get my laptop out to test it with Win10 (I do not normally allow Win10 attach to any important network), but both methods work on Windows 7 with 1.14.1.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Stephen19
Posts: 3
Joined: Wed Nov 14, 2018 4:08 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Stephen19 »

I'm fairly new to MakrMKV but I found with the last 2 updates that Windows 10 would not connect to my NAS drive immediately after updating. On both occasions I had used the "Start MKV" option at the end of the install process.

I use a limited rights user in Windows 10 and when I tried to browse to my NAS from within MakMKV it was asking for a username and password. That was strange because if I used Windows Explorer, I could browse the NAS with no issues. Because MakeMKV could not get to the NAS it reset its default paths which are normally pointing to the NAS.

It's as if MakeMKV is using an incorrect username and password when trying to connect to the nas drive but only the first time a new version runs.

To resolve this issue I quit MakeMKV and started it again. The second time it started after each update it was able to connect to the NAS drive with no problems.

You mention that you have "just updated" so I suspect you may have the same issue. Try quitting MakeMKV and starting it again to see if this solves the issue. Failing that try restarting your PC to see if this resolves the issue.

I hope this is of use.
Woodstock
Posts: 8613
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock »

We also have the "October surprise" Win10 update that was "fixed" and re-issued this week.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Stephen19
Posts: 3
Joined: Wed Nov 14, 2018 4:08 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Stephen19 »

I don't think that the Win10 update is the primary factor. Windows did not update in the 2-3 minutes between one version of MKV working fine and the updated version having authentication issues.

My suspicion is that the developer has accidentally hard coded the application to "run as" a specific user (possibly themselves) when launched from the "Launch MakeMKV" message at the end of the installer. My network is quite locked down so this would cause the application to be blocked from accessing any assets on the network and cause the behaviour that I have observed.
UrQuan3
Posts: 1
Joined: Sun Dec 22, 2019 9:00 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by UrQuan3 »

Thank you. Closing and reopening fixed it for me as well. This minor problem still exists in 1.14.7
Talontsi_95
Posts: 1
Joined: Sun Jan 09, 2022 4:15 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Talontsi_95 »

Sorry to bring up an old thread. I recently upgraded to the newest version of MakeMKV in order to rip my 4k blue rays. Previous version wouldnt decrypt the keys. I launched MakeMKV from the “installation complete” page and when trying to rip the blue ray it wouldn’t recognize my Synology NAS drive. I almost went through the remapping process but closed MakeMKV and re opened it. Suddenly the NAS drive is recognized and burning really well with my LG BE16NU50 version 1.01 drive.
chochb
Posts: 2
Joined: Fri Jan 14, 2022 8:32 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by chochb »

Talontsi_95 wrote:
Sun Jan 09, 2022 4:19 pm
Sorry to bring up an old thread. I recently upgraded to the newest version of MakeMKV in order to rip my 4k blue rays. Previous version wouldnt decrypt the keys. I launched MakeMKV from the “installation complete” page and when trying to rip the blue ray it wouldn’t recognize my Synology NAS drive. I almost went through the remapping process but closed MakeMKV and re opened it. Suddenly the NAS drive is recognized and burning really well with my LG BE16NU50 version 1.01 drive.
Hey, im looking forward to see about synology and makemkv! So I will switch to my Synology NAS. But makemkv doesn't map the drive. I hope u will help me, what's your config about devices? So we can't edit the yaml native!?

thx
Woodstock
Posts: 8613
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock »

MakeMKV works fine with network drives, both mapped to drive letters and as resources. I run MakeMKV to my Synology 18xx servers all the time.

How are you trying to address it?
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
chochb
Posts: 2
Joined: Fri Jan 14, 2022 8:32 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by chochb »

Woodstock wrote:
Fri Jan 14, 2022 9:12 pm
...
How are you trying to address it?
MakeMKV run with docker. that's fine. I think the problem are the "devices" in docker. With synology i can't map the devices in docker. Here is the log:

[cont-init.d] 95-check-optical-drive.sh: executing...
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: looking for usable optical drives...
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: found optical drive [-, /dev/sg8], but it is not usable because:
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: --> the host device - is not exposed to the container.
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: --> the host device /dev/sg8 is not exposed to the container.
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: no usable optical drive found.
stdout
15:39:46
[cont-init.d] 95-check-optical-drive.sh: exited 0.
Woodstock
Posts: 8613
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV 1.14.1 doesn't see network drives on Win10

Post by Woodstock »

Docker throws its own restrictions into the mix. MakeMKV itself can deal with it, but if you're using a third-party wrapper, the wrapper's permissions override what MakeMKV can do.
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging
Post Reply