Search found 21 matches

by Zirias
Fri Jul 08, 2022 7:43 am
Forum: MakeMKV for Linux
Topic: makemkvcon 1.16.5 crashes on FreeBSD
Replies: 2
Views: 1826

Re: makemkvcon 1.16.5 crashes on FreeBSD

I found a somewhat obscure solution! Compiling with -DFORCE_OPENSSL_NO_EC solves the problem. Not sure whether this problem is specific to FreeBSD's Linux compatibility or maybe to the OpenSSL version in Centos 7 ... just leaving it here for reference!
by Zirias
Thu Jun 02, 2022 9:38 am
Forum: MakeMKV for Linux
Topic: makemkvcon 1.16.5 crashes on FreeBSD
Replies: 2
Views: 1826

Re: makemkvcon 1.16.5 crashes on FreeBSD

This problem unfortunately persists in 1.16.7. So far, the last version working on FreeBSD is 1.16.4 :(
by Zirias
Tue Nov 02, 2021 5:10 pm
Forum: MakeMKV for Linux
Topic: makemkvcon 1.16.5 crashes on FreeBSD
Replies: 2
Views: 1826

makemkvcon 1.16.5 crashes on FreeBSD

I know this isn't supported anyways, but as it's the first version just crashing on FreeBSD, I thought you might have an idea which change might have caused that. The only thing I could think of for "debugging" is a "truss" log (similar to "strace" on linux) which might...
by Zirias
Mon Mar 22, 2021 8:16 am
Forum: MakeMKV for Linux
Topic: Error building 1.16.3
Replies: 5
Views: 4470

Re: Error building 1.16.3

The oss package updated in-place with this patch integrated. In the name of anyone packaging: Please don't do that. I just got a patch accepted against FreeBSD ports to update to 1.16.3 and now it fails to build on the official builders because they of course check filesize and checksum. As a resul...
by Zirias
Sun Feb 21, 2021 6:17 pm
Forum: MakeMKV for Linux
Topic: Question to all: MakeMKV without GUI, console only
Replies: 35
Views: 45246

Re: Question to all: MakeMKV without GUI, console only

Please give me some feedback if you are using MakeMKV without GUI, only the console app. This applies to any OS, but most of you do this on Linux, so that's why the question is posted here. Hi Mike, just so it isn't forgotten: On FreeBSD, GUI just doesn't work, because 'makemkvcon' running in Linux...
by Zirias
Sat Jul 25, 2020 7:04 pm
Forum: MakeMKV for Linux
Topic: How long will an older version continue to work?
Replies: 6
Views: 13162

Re: How long will an older version continue to work?

I still think there's some confusion about what I'm asking. Regardless of the beta key expiry -- makemkvcon will tell you that it won't run any more and you have to upgrade the software. What I want to know is the exact scheme when this error will be shown. It's a different error than the one about ...
by Zirias
Sat Jul 25, 2020 4:06 pm
Forum: MakeMKV for Linux
Topic: How long will an older version continue to work?
Replies: 6
Views: 13162

Re: How long will an older version continue to work?

I didn't ask about expiration of keys, but of program versions, that's a different topic.
by Zirias
Sat Jul 25, 2020 3:12 pm
Forum: MakeMKV for Linux
Topic: How long will an older version continue to work?
Replies: 6
Views: 13162

How long will an older version continue to work?

A few days ago, 1.15.1 refused to work, stating the version was too old. Today it worked again :?: Is this a random glitch?

In general, how long will a version continue to work after a new version is released? Would it be ok to keep 1.15.1 in a quarterly package repository until october?
by Zirias
Sun Apr 05, 2020 4:33 pm
Forum: General MakeMKV discussion
Topic: MakeMKV on FreeBSD
Replies: 20
Views: 33712

Re: MakeMKV on FreeBSD

The port just hit the official FreeBSD ports: https://www.freshports.org/multimedia/makemkv/ The main restriction is still that GUI won't work, and there are some annoyances on FreeBSD (namely having to build a custom kernel with "sg" devices, and the fact makemkvcon always crashes on exit...
by Zirias
Thu Mar 26, 2020 8:54 am
Forum: General MakeMKV discussion
Topic: MakeMKV on FreeBSD
Replies: 20
Views: 33712

Re: MakeMKV on FreeBSD

The port is now updated to 1.15.0
It will take a lot of time to build because building a whole GNU toolchain is needed to get a libstdc++.so.6 which is compatible with the new makemkvcon binary (the version in FreeBSD's linux-c7 ports is too old)
by Zirias
Tue Mar 24, 2020 11:34 pm
Forum: MakeMKV for Linux
Topic: MakeMKV v1.15.0 Application failed to initialize
Replies: 3
Views: 7412

Re: MakeMKV v1.15.0 Application failed to initialize

@old-linux that's why I suggested to mike to build with a static libstdc++ ;) Yes, makemkvcon is closed source. If you want to run it unmodified, your best bet is to upgrade your system. Your second best bet is to install a newer GNU toolchain from source locally, but that's pretty though... Right n...
by Zirias
Mon Mar 23, 2020 11:22 pm
Forum: MakeMKV for Linux
Topic: MakeMKV v1.15.0 Application failed to initialize
Replies: 3
Views: 7412

Re: MakeMKV v1.15.0 Application failed to initialize

I have the same problem trying to update my FreeBSD port to 1.15.0 -- FreeBSD uses Centos 7 packages for Linux compatibility, so libstdc++ comes from GCC 4.8. It seems makemkvcon now needs at least the version from GCC 5.2 :( @mike, maybe you could build makemkvcon with "-static-libstdc++ -stat...
by Zirias
Mon May 06, 2019 6:17 am
Forum: MakeMKV for Linux
Topic: FreeBSD with Linux compatibility: makemkvcon works, but not in guiserver mode
Replies: 1
Views: 5250

Re: FreeBSD with Linux compatibility: makemkvcon works, but not in guiserver mode

Some help from somebody who knows the source would be quite nice. I'm almost there with porting, my port builds and installs MakeMKV console-only automatically and it runs fine*). A second port could build the Qt GUI (probably to a native FreeBSD binary), but as long as "makenkvcon guiserver G0...
by Zirias
Sun May 05, 2019 1:50 pm
Forum: General MakeMKV discussion
Topic: MakeMKV on FreeBSD
Replies: 20
Views: 33712

Re: MakeMKV on FreeBSD

For anyone who's interested, there's also a Port now, building and installing this console-only version:
https://github.com/Zirias/zfbsd-ports/t ... ia/makemkv
by Zirias
Thu May 02, 2019 2:03 pm
Forum: MakeMKV for Linux
Topic: GLIBC_2.28 not found on Ubuntu
Replies: 9
Views: 25448

Re: GLIBC_2.28 not found on Ubuntu

Just a hint, almost every Makefile includes a "clean" target, so all you have to do is start with "make clean" before you rebuild.